Subversion Repositories ALCASAR

Rev

Rev 2488 | Rev 2520 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed

#!/bin/bash
# $Id: alcasar-urpmi.sh 2489 2018-02-25 23:43:08Z tom.houdayer $

# alcasar-urpmi.sh
# by 3abtux and Rexy
# This script is distributed under the Gnu General Public License (GPL)

# script de mise en place des dépots RPM
# configure the RPM repository

Lang=`echo $LANG|cut -c 1-2`
VERSION="6"
ARCH="x86_64"
# The kernel version we compile netflow for
KERNEL="kernel-server-4.14.20-1.mga6-1-1.mga6"
# ****** Alcasar needed RPMS - paquetages nécessaires au fonctionnement d'Alcasar ******
PACKAGES="arp-scan vim-enhanced freeradius freeradius-mysql freeradius-ldap lighttpd lighttpd-mod_auth php-fpm dansguardian postfix mariadb ntp bind-utils openssh-server php-xml php-ldap php-mysqli php-mbstring php-sockets php-cli php-curl php-pdo_sqlite php-json rng-utils rsync clamav perl-rrdtool perl-MailTools perl-Socket6 fail2ban gnupg ulogd pm-fallback-policy ipset cronie-anacron gammu usbutils locales-en usb_modeswitch tinyproxy vnstat php-gd sudo iftop man dos2unix p7zip bc msec kernel-userspace-headers dnsmasq netcat-traditional"

rpm_repository_sync ()
{
cat <<EOF > /etc/urpmi/urpmi.cfg
{
downloader: wget
}
EOF
echo ${!MIRRORLIST}
urpmi.addmedia core --probe-synthesis --mirrorlist ${!MIRRORLIST} /media/core/release
urpmi.addmedia core-updates --update --probe-synthesis --mirrorlist ${!MIRRORLIST} /media/core/updates
urpmi.addmedia nonfree --probe-synthesis --mirrorlist ${!MIRRORLIST} /media/nonfree/release
urpmi.addmedia nonfree-updates --update --probe-synthesis --mirrorlist ${!MIRRORLIST} /media/nonfree/updates
}

rpm_error ()
{
echo
if [ $Lang == "fr" ]
then
        echo "Relancez l'installation ultérieurement."
        echo "Si vous rencontrez à nouveau ce problème, modifier les variables MIRRORLIST[1&2] du fichier 'scripts/alcasar-urpmi.sh'"
else
        echo "Try an other install later."
        echo "If this problem occurs again, change the MIRRORLIST[1&2] variables in the file 'scripts/alcasar-urpmi.sh'"
fi
}

# extract the current Mageia version and hardware architecture (i586 ou X64)
fic=`cat /etc/product.id`
old="$IFS"
IFS=","
set $fic
for i in $*
do
        if [ "`echo $i|grep distribution|cut -d'=' -f1`" == "distribution" ]
        then
                DISTRIBUTION=`echo $i|cut -d"=" -f2`
        fi
        if [ "`echo $i|grep version|cut -d'=' -f1`" == "version" ]
        then
                CURRENT_VERSION=`echo $i|cut -d"=" -f2`
        fi
        if [ "`echo $i|grep arch|cut -d'=' -f1`" == "arch" ]
        then
                ARCH=`echo $i|cut -d"=" -f2`
        fi
done
IFS="$old"

# We prefer wget than curl
urpmi --no-verify-rpm --auto rpms/$ARCH/wget*.rpm

# Set the RPM repository (if not already set)
ACTIVE_REPO=`cat /etc/urpmi/urpmi.cfg|grep "mageia.org"|wc -l`
MIRROR_NBR=2
#                       For Europeans
MIRRORLIST1="http://www.mirrorservice.org/sites/mageia.org/pub/mageia/distrib/$VERSION/$ARCH"
#                       For International install
MIRRORLIST2="http://mirrors.mageia.org/api/mageia.$VERSION.$ARCH.list"
try_nb="0"; nb_repository="0"
while [ "$nb_repository" != "4" ]
do
        try_nb=`expr $try_nb + 1`
        MIRRORLIST="MIRRORLIST$try_nb"
        rpm_repository_sync
        nb_repository=`cat /etc/urpmi/urpmi.cfg|grep mirrorlist|wc -l`
        if [ "$nb_repository" != "4" ]
        then
                if [ $Lang == "fr" ]
                then
                        echo "Une erreur a été détectée lors de la synchronisation avec le dépot N°$try_nb."
                else
                        echo "An error occurs when synchronising the repositories N°$try_nb"
                fi
                if [ $(expr $try_nb) -eq $MIRROR_NBR ]
                then
                        rpm_error
                        exit 1
                fi
                if [ $Lang == "fr" ]
                then
                        echo "Voulez-vous tenter une synchronisation avec un autre dépôt ? (O/n)"
                else
                        echo "Do you wan't to try a synchronisation with an other repository? (Y/n)"
                fi
                response=0
                PTN='^[oOnNyY]$'
                until [[ $(expr $response : $PTN) -gt 0 ]]
                do
                        read response
                done
                if [ "$response" = "n" ] || [ "$response" = "N" ]
                then
                        exit 1
                fi
        fi
done

# download the kernel used by ALCASAR and fix its version
if [ $Lang == "fr" ]
then
        echo "Récupération du noyau Linux exploité par ALCASAR. Veuillez patienter ..."
else
        echo "Download the Linux kernel used by ALCASAR. Please wait ..."
fi
echo "/^kernel/" > /etc/urpmi/skip.list
urpmi --auto --quiet $KERNEL
# download updated RPM in cache
if [ $Lang == "fr" ]
then
        echo "Récupération des paquetages de mise à jour. Veuillez patienter ..."
        echo "Il est temps d'aller prendre un café (ou une bonne bière) ;-)"
else
        echo "Updated RPM download. Please wait ..."
        echo "You should now take a coffe (or a good beer) ;-)"
fi
urpmi --auto --auto-update --quiet --test --retry 2
if [ "$?" != "0" ]
then
        echo
        if [ $Lang == "fr" ]
        then
                echo "Une erreur a été détectée lors de la récupération des paquetages."
        else
                echo "An error occurs when downloading RPMS"
        fi
        rpm_error
        exit 1
fi

# update with cached RPM
urpmi --auto --auto-update
if [ "$?" != "0" ]
then
        echo
        if [ $Lang == "fr" ]
        then
                echo "Une erreur a été détectée lors de la mise à jour des paquetages."
        else
                echo "An error occurs when updating packages"
        fi
        rpm_error
        exit 1
fi
# Clean the RPM cache
urpmi --clean

# Download of ALCASAR specifics RPM in cache (and test)
if [ $Lang == "fr" ]
then
        echo "Récupération des paquetages complémentaires. Veuillez patienter ..."
else
        echo "Download of complementary packages. Please wait ..."
fi
urpmi --auto $PACKAGES --quiet --test --retry 2
if [ "$?" != "0" ]
then
        echo
        if [ $Lang == "fr" ]
        then
                echo "Une erreur a été détectée lors de la récupération des paquetages complémentaires."
        else
                echo "An error occurs when downloading complementary packages"
        fi
        rpm_error
        exit 1
fi

# update with cached RPM
urpmi --auto $PACKAGES
if [ "$?" != "0" ]
then
        echo
        if [ $Lang == "fr" ]
        then
                echo "Une erreur a été détectée lors de l'installation des paquetages complémentaires."
        else
                echo "An error occurs when installing complementary packages"
        fi
        rpm_error
        exit 1
fi

# Keep only the kernel version we compil netflow with, and remove all others
kernelVersion=$(rpm -qa | grep -e ^kernel-server -e ^kernel-desktop)
for i in $kernelVersion
do
        if [ $i != $KERNEL ];then
                urpme --auto $i
        fi
done
# delete unused RPMs
if [ $Lang == "fr" ]
then
        echo "Cleaning the system : "
else
        echo "Nettoyage du système : "
fi
rm_rpm="shorewall mandi squid plymouth cpupower apache apache-mod_php apache-mod_ssl"
/usr/sbin/urpme --auto -a $rm_rpm
/usr/sbin/urpme --auto --auto-orphans

# Save chilli launch script (erase with new rpm one)
[ -e /etc/chilli.conf ] && cp /etc/chilli.conf /tmp/
# Install home made RPMs
urpmi --no-verify --auto rpms/$ARCH/*.rpm
# restore chilli launch script
[ -e /tmp/chilli.conf ] && mv /tmp/chilli.conf /etc/
# Clean the RPM cache
urpmi --clean
# the ipt-netflow RPM add the kernel module ipt_NETFLOW (the modules dependance tree need to be updated)
/sbin/depmod -a
exit 0