Subversion Repositories ALCASAR

Rev

Rev 1096 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log

Rev 1096 Rev 1404
1
Summary: HTTP anti-virus proxy filter
1
Summary: HTTP anti-virus proxy filter
2
Name: havp
2
Name: havp
3
Version: 0.92a
3
Version: 0.92a
4
Release: %mkrel 1.1%{?dist}
4
Release: %mkrel 1.1%{?dist}
5
License: GPLv2+
5
License: GPLv2+
6
Group: Security
6
Group: Security
7
URL: http://www.server-side.de/
7
URL: http://www.server-side.de/
8
Source: http://www.server-side.de/download/havp-%{version}.tar.gz
8
Source: http://www.server-side.de/download/havp-%{version}.tar.gz
9
Packager: Francois Crosnier (Crox) ALCASAR team
9
Packager: jb (ALCASAR team)
10
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
BuildRequires: clamav-devel
11
BuildRequires: clamav-devel
12
 
12
 
13
%description
13
%description
14
HAVP (HTTP AntiVirus proxy) is a proxy with an anti-virus filter.
14
HAVP (HTTP AntiVirus proxy) is a proxy with an anti-virus filter.
15
It does not cache or filter content. At the moment the complete
15
It does not cache or filter content. At the moment the complete
16
traffic is scanned. The reason for this is the chance of malicious
16
traffic is scanned. The reason for this is the chance of malicious
17
code in nearly every filetype e.g. HTML (JavaScript) or Jpeg.
17
code in nearly every filetype e.g. HTML (JavaScript) or Jpeg.
18
 
18
 
19
I aim to stop especially dialer or browser exploits. But writing
19
I aim to stop especially dialer or browser exploits. But writing
20
a http Anti Virus Proxy is a real dilemma! Huge downloads are
20
a http Anti Virus Proxy is a real dilemma! Huge downloads are
21
a problem for virus scanning proxies. A Client should not receive
21
a problem for virus scanning proxies. A Client should not receive
22
data which is unchecked by the virus scanner, but big downloads
22
data which is unchecked by the virus scanner, but big downloads
23
should not timeout.
23
should not timeout.
24
 
24
 
25
%prep
25
%prep
26
%setup
26
%setup
27
 
27
 
28
%build
28
%build
29
%configure
29
%configure
30
%make
30
%make
31
 
31
 
32
%install
32
%install
33
rm -rf %{buildroot}
33
rm -rf %{buildroot}
34
install -d %{buildroot}%{_initrddir}
34
install -d %{buildroot}%{_initrddir}
35
cp etc/init.d/havp %{buildroot}%{_initrddir}/havp
35
cp etc/init.d/havp %{buildroot}%{_initrddir}/havp
-
 
36
install -d %{buildroot}/lib/systemd/system/
-
 
37
cp lib/systemd/system/havp.service %{buildroot}/lib/systemd/system/
36
install -d %{buildroot}%{_localstatedir}/run/havp/
38
install -d %{buildroot}%{_localstatedir}/run/havp/
37
install -d %{buildroot}%{_localstatedir}/log/havp/
39
install -d %{buildroot}%{_localstatedir}/log/havp/
38
%makeinstall
40
%makeinstall
39
 
41
 
40
%pre
42
%pre
41
if ! /usr/bin/id havp &>/dev/null; then
43
if ! /usr/bin/id havp &>/dev/null; then
42
	/usr/sbin/useradd -r -d %{_localstatedir}/log/havp -s /bin/sh -c "havp" havp || \
44
	/usr/sbin/useradd -r -d %{_localstatedir}/log/havp -s /bin/sh -c "havp" havp || \
43
		%logmsg "Unexpected error adding user \"havp\". Aborting installation."
45
		%logmsg "Unexpected error adding user \"havp\". Aborting installation."
44
fi
46
fi
45
 
47
 
46
%post
48
%post
47
/sbin/chkconfig --add havp
49
/usr/bin/systemctl -q enable havp.service
48
 
50
 
49
%preun
51
%preun
50
if [ $1 -eq 0 ]; then
52
if [ $1 -eq 0 ]; then
51
	/sbin/service havp stop &>/dev/null || :
53
	/usr/bin/systemctl havp stop
52
	/sbin/chkconfig --del havp
54
	/usr/bin/systemctl -q disable havp.service
53
fi
55
fi
54
 
56
 
55
%postun
57
%postun
56
if [ $1 -eq 0 ]; then
58
if [ $1 -eq 0 ]; then
57
	/usr/sbin/userdel havp || %logmsg "User \"havp\" could not be deleted."
59
	/usr/sbin/userdel havp || %logmsg "User \"havp\" could not be deleted."
-
 
60
	rm -f /lib/systemd/system/havp.service
58
fi
61
fi
59
 
62
 
60
%files
63
%files
61
%defattr(-, root, root, 0755)
64
%defattr(-, root, root, 0755)
62
%doc ChangeLog COPYING INSTALL update-conf
65
%doc ChangeLog COPYING INSTALL update-conf
63
%config %{_sysconfdir}/havp/
66
%config %{_sysconfdir}/havp/
64
%config %{_initrddir}/havp
67
%config %{_initrddir}/havp
65
%{_sbindir}/havp
68
%{_sbindir}/havp
-
 
69
/lib/systemd/system/havp.service
66
 
70
 
67
%defattr(-, havp, havp, 0755)
71
%defattr(-, havp, havp, 0755)
68
%{_localstatedir}/log/havp/
72
%{_localstatedir}/log/havp/
69
%{_localstatedir}/run/havp/
73
%{_localstatedir}/run/havp/
70
 
74
 
71
%changelog
75
%changelog
-
 
76
* Thu Jul 07 2014 jb <jeanbaptiste.couprit@gmail.com> (x86_64 & i586) - 0.92-1.1
-
 
77
- Created .spec file to build rpms for Mageia4 (x86_64 & i586).
-
 
78
- Created two rpms : havp-0.92a-1-1.mga4.x86_64.rpm & havp-0.92a-1-1.mga4.i586.rpm with Libclamav patch (OpenSSL)
-
 
79
 
72
* Tue Apr 30 2013 Crox <ptitois@gmail.com> - 0.92-1.1
80
* Tue Apr 30 2013 Crox <ptitois@gmail.com> - 0.92-1.1
73
- Created .spec file to build rpms for Mageia2 (x86_64 & i586).
81
- Created .spec file to build rpms for Mageia2 (x86_64 & i586).
74
- Created two rpms : havp-0.92a-1-1.mga2.x86_64.rpm &  havp-0.92a-1-1.mga2.i586.rpm
82
- Created two rpms : havp-0.92a-1-1.mga2.x86_64.rpm &  havp-0.92a-1-1.mga2.i586.rpm
75
 
83
 
76
* Sun Nov 21 2010 Rexy <richard@rexy.fr> - 0.92-1
84
* Sun Nov 21 2010 Rexy <richard@rexy.fr> - 0.92-1
-
 
85
 
77
- Updated to release 0.92a.
86
- Updated to release 0.92a.
78
 
87
 
79
* Sun May  9 2010 Rexy <richard@irexy.fr> - 0.91-1
88
* Sun May  9 2010 Rexy <richard@irexy.fr> - 0.91-1
80
- Updated to release 0.91.
89
- Updated to release 0.91.
81
 
90
 
82
* Tue Apr  7 2009 Dries Verachtert <dries@ulyssis.org> - 0.90-1
91
* Tue Apr  7 2009 Dries Verachtert <dries@ulyssis.org> - 0.90-1
83
- Updated to release 0.90.
92
- Updated to release 0.90.
84
 
93
 
85
* Wed Aug 13 2008 Dries Verachtert <dries@ulyssis.org> - 0.89-1
94
* Wed Aug 13 2008 Dries Verachtert <dries@ulyssis.org> - 0.89-1
86
- Updated to release 0.89.
95
- Updated to release 0.89.
87
 
96
 
88
* Sun Apr 20 2008 Dries Verachtert <dries@ulyssis.org> - 0.88-1
97
* Sun Apr 20 2008 Dries Verachtert <dries@ulyssis.org> - 0.88-1
89
- Updated to release 0.88.
98
- Updated to release 0.88.
90
 
99
 
91
* Mon Jul 23 2007 Dries Verachtert <dries@ulyssis.org> - 0.86-1
100
* Mon Jul 23 2007 Dries Verachtert <dries@ulyssis.org> - 0.86-1
92
- Updated to release 0.86.
101
- Updated to release 0.86.
93
 
102
 
94
* Tue Aug 22 2006 Dag Wieers <dag@wieers.com> - 0.7.9-1
103
* Tue Aug 22 2006 Dag Wieers <dag@wieers.com> - 0.7.9-1
95
- Cosmetic changes.
104
- Cosmetic changes.
96
 
105
 
97
* Wed May 31 2006 Bernard 'Tux' Lheureux <tux at portalinux dot org> 0.7.9-2
106
* Wed May 31 2006 Bernard 'Tux' Lheureux <tux at portalinux dot org> 0.7.9-2
98
- Corrected the specfile to make it installable on CentOS 4.x
107
- Corrected the specfile to make it installable on CentOS 4.x
99
- Created and applied some patches to make it chkconfig compatible
108
- Created and applied some patches to make it chkconfig compatible
100
- Created and applied a patch to make config reflect the correct location of the files
109
- Created and applied a patch to make config reflect the correct location of the files
101
 
110
 
102
* Tue May 30 2006 Jim Perrin <jperrin at gmail dot com> 0.7.9-1
111
* Tue May 30 2006 Jim Perrin <jperrin at gmail dot com> 0.7.9-1
103
- Initial build for CentOS,
112
- Initial build for CentOS,
104
- Specfile generation... still some work to do...
113
- Specfile generation... still some work to do...
105
 
114
 
106
 
115